Working hours: Mo-Fr, 9:00-20:00 CET. Before sending a ticket to support, make sure that you read the documentation and also look for similar tickets. Thanks!

Raise Funds for Ukraine’s Armed Forces

Okay
  Print

"The Link You Followed Has Expired" when Installing Theme/Plugin

This guide will show you how to easily fix “The link you followed has expired” error when installing a WordPress theme. This is a common error and occurs if you are installing a theme in Appearance > Themes > Add new OR Plugins > Add new.

the link you followed has expired

It means that your server is configured with PHP settings that are too low to allow the theme zip file to upload.  Specifically, the maximum file upload limit is less than the theme zip file and should be adjusted. 

There are two ways to solve the issue. 

  • Increasing max_file_upload_size on your server to 32M. You may check this guide for detailed information. If you are not familiar with your server configuration, contact your hosting provider and ask for their help.
  • Alternatively, upload the extracted theme package via an FTP client to the wp-content/themes directory.

We recommend that you contact your web hosting service provider to make sure that your server PHP configuration limits are as follows:

  • max_execution_time 600
  • memory_limit 256M
  • post_max_size 32M
  • upload_max_filesize 32M